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Preface

This guide provides information on getting started with and using XML Pro. This guide is for anyone that creates or
edits XML (Xtensible Markup Language) documents and assumes the user has some familiarity with XML.

How This Guide Is Organized
This guide contains the following chapters:

Chapter 1: Menus and Tool Bar
Chapter 2: Elements, Attributes and Entities

Chapter 3: Document Type Definition, PCDATA, CDATA & Comments

Guide Conventions

Main chapter topics or XML Pro features are displayed inbold text.
Menu commands or buttons are displayed in italic fext.

Error messages are displayed in courier text.

Technical Support

For any questions regarding problems using XML Pro, please dial (812) 856-5270 between 8 am and 5 pm, CST (Cen-
tral Standard Time), Monday through Friday or email support@vetvet.com with your question.



Chapter ., , \IENUS AND TOOL BAR

This chapter discusses the XML Pro Pull-down Menus and the Tool Bar. XML Menus

provide menu access to all file, editing, and document commands available with XML Pro.

Commands listed in these menus can also be activated by using the .4/ key in conjunction
with an alphabetical key.
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Figure 1-1 Menn Bar

First select the .4/ key combination to display the menu, and then use the appropriate .4/ key combination to access
the commands on that menu. Fach command is shown with the corresponding keystroke command in brackets. For
example, pressing A/ and the F key displays the File menu.

NOTE: Some A/t sequences may be duplicated, so be sure to first select the correct menu.
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1.1 File Menu (Alt + F)

New (Alt + N): Creates a new XML document. Before it is created, you must specify the name
for the file with a . XML extension.

Open (Alt + O): Launches the Fik Open dialog box, letting you open an existing XML file for
editing.

Save (Alt + S): Saves the currently open file with the name displayed in the window's Title Bar.

Exit Save As (Alt + A): Lets you re-name the currently open file, and/or save the file to another loca-
tion.

Print (Alt +P): Opens the Print File dialog box, letting you change the printer settings for the document (if needed),
and then prints the current document to your attached printet.

Close (Alt + C): Closes the currently open document. If the document has been edited, but not saved, you will be
prompted on screen to save the document before closing it.

Exit (Alt + X): Closes XML Pro. If you have an unsaved, open document, you will be prompted on screen to save it
before exiting XML Pro.
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& Cut

Copy Cut (Ctrl + X): Remove selected text from the current editing window. Cut text is copied to the clip-

E Pazte

&) Find Copy (Cttl + C): Copies the selected text into the clipboard, so that it can be pasted into the docu-
: ment at another location.

1.2 Edit Menu (Alt + E)

board, so that it can be pasted into the document at another location.

Paste (Ctrl + P): Inserts the clipboard contents (from previous cut or copy operations) into the document at the cur-
rent cursor location.

Find (Alt + F): Opens the Find dialog, letting you search the currently open document for instances of a particular
word or phrase.

Options  Help

- Element Wizard 1.3 Tools Menu (Alt + T)

E Attribute Wizard

Element Wizard (Alt + E): Launches the XML Pro Element Wizard, which is used to cre-
ate, remove, and manage element types in the currently open document.

& pove Element Up
¥ bove Element Down

Delete Element

Attribute Wizard (Alt + A): Launches the XML Pro Attribute Wizard, which lets you create,

remove, and manage attribute types for elements in the currently open document.
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Move Element Up (Alt + U): Moves a selected item one line up in the document structure.
Move Element Down (Alt + D): Moves a selected item one line down in the document structure.

Delete Element (Alt + 1): Removes the selected item from the document structure, however element types are not
removed entirely, and instead are placed in the clipboard temporarily.

Validate (Alt + V): Validates the currently open document's content against a Document Type Definition (DTD), if
one has been specified. A DTD is a document in the same directory as the current XML file you are working on that
has guidelines for what will be in the file you are working on. If one has not been selected for the document, valida-
tion will not be available.

Associate DTD (Alt + A): Launches the Associate DTD dialog, which lets you assign a DTD to the currently open
document, or to remove a DTD association from the currently open document.

View XML (Alt + w): Displays on screen the XML Code that is generated in the document file, so you can look at
the exact text that will be written to the file for the currently open document.
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 Vew PEDATA Tt e 1.4 Options Menu (Alt + O)

Yiew Attributes in Tree

View PCDATA Text in Tree (Alt + P): Toggles between Icon View and Full Text
Show Element Palgtte View for document tree PCDATA.

Show Entiy Palette . . . . . .
t View Attributes in Tree (Alt + A): Lets you view element attributes in the document

V' Aalable Eleneris Constaned By0TD | tree next to the appropriate element, as well as in the Attribute Window for editing.

Show Element Palette (Alt + E): Displays the Element Palette
Show Entity Palette (Alt + n): Displays the Entity Palette.

Available Elements Constrained by DTD (Alt + C): Restricts adding elements on the currently open document to
only those valid as children of the selected element, according to the document's assigned DTD. This is only active
when a DTD association has been made and can help prevent you from accidentally creating an invalid document
when working with a DTD.

(2] #ML ProHelp
About

1.5 Help Menu (Alt + H)
XML Pro Help (Alt + X): Launches the online help documentation in your associated web

browset.

About (Alt + A): Opens the XML Pro about dialog box.

1.6 Pop-up Menu

Add COATA

Add Comment
Delete

Move Lp file is open. The pop-up menu contains the following options:
Mirve Dawir

This displays when you click on the right mouse button. It only displays when a document

Expand Beneath
_elepszBenedh | o Adld Element - Adds an element

¢ Add PCDATA - Adds PCDTA (parsed character data)
e Add CDATA - Add CDATA (character data)

e Add Comment- Adds comments

» Delete- Deletes selected item

* Move Up- Moves selected item up one line

* Move Down- Moves selected item down one line

e Expand Beneath- Displays any additional data beneath the selected item.



» Collapse Beneath Removes the display of additional data beneath the selected item

1.7. Tool Bar
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Figure 1-2. Tool Bar

Tool Bar icons displayed from left to right are:

* New -Opens a new file

¢ Open -Opens an existing file

* Save -Saves a file

* Print - Prints a file

* Cut - Deletes selected text

e Copy - Copies selected text

» Paste -Inserts selected text

* Element Wizard - Displays theElement Wizard
e Attribute Wizard - Displays theAttribute Wizard
e Move Up - Moves selected item up one line

* Move Down -Moves selected item down one line

» Validate - Validates the currently open document's content against a DTD.



Chapter , 1 EMENTS, ATTRIBUTES AND ENTITIES

This chapter discusses elements, attributes and entities and how to work with them in
XML Pro. Elements are the foundations of XML documents. Attributes and entities are
designed to further describe an element. XML Pro has features designed to make creating,
deleting and managing of elements simple. Two of them are the Element Wizard and the Element Palette.

2.1 Element Wizard
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Figure 2-1 Element Wizard

Use the Element Wizard to create and remove element types for inclusion into the current document. When used in
conjunction with a DTD, the Element Wizard only displays elements defined by the DTD, and does not allow ele-
ments to be removed.

If the DTD does allow creating new elements for the document, the Element Wizard can be used to create (and
remove) new element types for it.

The Wizard contains three components:

* Elements(a list of currently defined elements)
* Name New Elementga text field beneath the Elements display)

e Add, Remove, and Closduttons. Add lets you add a new element to the list, Remove
deletes it, and Close exits the Wizard window.



2.1.1 Creating a New Element Using Element Wizard

Use the Element Wizard to create new Element types for your document. Follow these steps:
1. Launch the Element Wizard from the Toolbar or Tools menu.

2. Enter the element name in the New Element Name field. Element names are case sensitive; keep
this in mind when creating new element types.

3. Click on the Add button to create the new element type.

2.1.2 Deleting an Existing Element Type Using Element Wizard
To delete an element type:

1. Select the Element type to be deleted from the list of Elements shown.

2. Click the Remove button.

3. Removing an Element from the Element Wizard removes it from your document entirely,
including any information that is currently defined in existing elements. Before the element is
removed, you will be prompted on screen to confirm that you want to remove the Element
before proceeding, Once you click the OK button, the Flement type, and any instances of it in
your document are removed. Click the Close button to close the Wizard and return to your doc-

ument.
2.2 The Element Palette
Li
The Element Palette is a floating window that lists all available element types for the current
ALBUM open document.
SRATIST
COCOLLECTION
LABEL 2.2.1 Inserting Elements Using the Element Palette
TITLE
TRALEK. To insert an Element listed in the Element Palette into the current document, follow these
steps:
1. Select the insertion point for the new element in the document.
2. Select the element type you want to add, and click the Inserz button. The new element is
now added to your document.
Inzert

If you are working with a DTD, and have selected the Available Elements Constrained by D'T'D option, elements shown in
the Element Palette will change, depending on where in the document you are trying to insert the new element.



2.2.2 Sorting Elements

Elements displayed in the Element Palette are sorted in alphabetical order. If you have elements that are defined in a
DTD, and then you create new elements, element types defined within the DTD will be displayed first, sorted alpha-
betically. Following the DTD defined elements will be any custom elements, grouped together and also sorted alpha-
betically.

2.3 Elements in the Document

Besides the Element Wizard and the Element Palette, XML Pro has other ways to insert, delete, and or move ele-
ments. While you must use the Element Wizard to create and remove element types, you can add individual
instances of each element directly to the document tree.

2.4 Inserting Elements

Elements can be inserted using the Element Palette, or by inserting them from directly within the document tree
view (the window displaying the document on screen). To insert an element within the tree:

1. Right click on the insertion point within the tree view.

2. From the Pop-up menu (which displays by clicking your right mouse button), select the .Add Ele-
ment sub-menu, and then highlight the element you wish to insert.

3. Release the mouse button, and the new element is inserted.

NOTE: The Add Element sub-menu is limited to displaying 15 elements. If your document con-
tains more then 15, you will need to use the Element Palette to display all available element types.

2.5 Deleting Elements

Element types can only be removed by using the Element Wizard. Single occurrences of an element within a docu-
ment can be deleted in one of two ways:

1. Select the element to be deleted within the document tree view:
2. Select Delete Element from the Tools menu.

or

* Right click on the element to be removed, and select De/ete from the Pop-up menu. The root ele-
ment of a document cannot be deleted.

2.6 Moving Elements

Elements shown in the document tree view can be repositioned in one of three ways:

1. Right click on the element to be moved, and select Move Up or Move Down from the Pop-up

menu.



2. Select the element to be moved, and then choose Move Element Up or Move Element Down from the
Tools Menu.

3. Select the element to be moved, and use the up and down arrows on the toolbar to reposition the
element.

2.7 Attributes

Attributes let you further customize elements to provide more information about them.

2.8 Attribute Wizard

The Attribute Wizard assigns attributes to elements, and also removes attributes from them.
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Figure 2.2 Attribute Wizard

This Wizard contains three components:

* Elements (the list of element types or "tags" that are currently available in the document, either
as defined in the document's DTD or added by the user in the Element Wizard)

* New Attribute Name (a text field where a new attribute name can be entered)

* Add, Remove, and Close buttons. Add lets you add a new attribute to the list, Remove deletes
it, and Close exits the Wizard window.

2.8.1 Creating New Attributes

Follow these steps to create a new attribute for an element type:
1. Launch the Attribute Wizard.

10



2. Select the element type you want to add the attribute to.

3. Enter the attribute name in the New Atfribute Namse field. Attribute names are case sensitive, so

tpe will be treated differently from #pe.

4. Click Add, and the new attribute type appears in the Attributes list on the right. This attribute is
now available for all elements of the selected type, and will appear in the Attributes Pane within
the Editor.

2.8.2 Deleting Existing Attributes

Follow these steps to delete an exiting attribute type from an element:
1. Launch the Attribute Wizard.

2. Select the element from the Elements list, and then select the Attribute you wish to remove from
the Attribute list.

3. Click Remove to remove the attribute.

4. You are prompted to confirm that you want to remove the attribute type. Removing the attribute
type will delete all occurrences of the attribute from your document, including any values that
might be assigned to the attribute. Once the attribute is removed, old values will be lost. If you
do want to remove the attribute, select "OK" and it is removed.

2.8.3 Attributes with DTD's

When you are working with a document that has an Document Type Definition (DTD) associated with it, attributes
for elements defined within the DTD cannot be modified via the Attribute Wizard. This is because of the constraints
placed on it by the DTD.

2.8.4 Attributes in the Document

When you are editing a document in XML Pro, and you click on an element in the tree view that has an assigned
attribute, the attribute appears in the Attribute Pane of the Editor.

11
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Figure 2-3. Attribute Pane

From the Attribute Pane, you can enter, delete, or edit the values that have been assigned to element attributes in
your document. You may also use the cut, copy, and paste editing features within the Attribute Pane when working
with attribute values.

2.8.5 Assigning Values to Attributes

To assign a value to an attribute, follow these steps:
1. Click on the element with the attribute. The attribute appears in the Attribute Pane.
2. Enter a value for the attribute in the text field next to the attribute name.

NOTE: There is no confirmation button in the Attribute Pane. Once you have entered a value, if you select another
element, the value is committed to memory. If the attribute is specified in the DTD as enumeration, the fixed choices
will be presented within a drop-down list box.

2.8.6 How Attributes are Written

When you create attributes for an element, the attribute always appears in the Attribute Pane when that element is

selected in the tree view,

However, you do not need to assign a value to all instances of that attribute in all elements. Only attributes that have
values assigned are written to the final XML Code. This keeps your code from getting "empty attributes" which are
not necessary to specify. To preview what attribute values are being written, use the [7Zew XML feature in the Tools

Menu.

2.8.7 Viewing Attributes in Document Tree

XML Pro displays element attributes in the Attribute Pane, when an element is selected. To view all attributes for all
elements within the tree view, select the [iew Attributes in Tree option from the Options menu. When selected, this

option displays an element's attributes adjacent to the element in the document tree view:
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2.9 Entities

Entities provide another way to customize an element in an XML document. Because Entities are defined within a
document's DTD, XML Pro does not have a way to create or remove actual entities. However, you can list the Enti-
ties that are available to a document, and insert defined Entities into a2 document.

2.9.1 The Entity Palette

i NEnfities

The Entity Palette is a separate floating window that can be hidden or shown by selecting the

EMAIL
ALUTHOR Show Entity Palette option, found in the Options Menu. The window displays a list of the Entities
COMPANY that have been defined in the DTD, as shown on the left.

The Entity Palette can then be used to see the available Entities, and to insert them into the doc-
ument.

2.10 Adding an Entity

There are two ways to add an entity to the current document:

[nzert |

1. After selecting the insertion point in the document, select the desired entity from the Entity
Palette, and click Insert.

2. Right click on the desired item you wish to insert the Entity into, and select .Add Entity from the
Pop-up Menu. Under the Add Entity sub-menu (shown on the next page), you will see another
listing of the available Entities. Select the entity you wish to add and release the mouse. Only the
first 15 entities are available on the sub-menu.

|| FARTHUM [
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&dd CDATA AUTHOR

Add Commment
Delete

COMPANY

bove Up
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Collapze Beneath

Fignre 24. Add Entity Sub-menn
2.11 Removing an Entity
There are two ways to remove an entity from the current document:

1. Right click on the Entity you wish to remove, and select Defete.

2. Select the Entity you wish to remove, and select Delete Element trom the Tools menu. This also
deletes the Entity instance from the document.
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These methods do not affect the Entity's availability in the Entity Palette, because Entities ate defined within the
DTD.
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Chapter ; 1OCUMENT TYPE DEFINITION, PCDATA,

CDATA & COMMENTS

This chapter desctibes how XML Pro handles other important XML features: Document
Type Definition (DTD) files, PCDATA, CDATA, and comments. Document Type Def-
inition files desctibe what an XML file will look like. PCDATA is 'parsed' character data, CDATA represents character
data other than what is already described by entities and attributes. Comments are simply additional remarks about an

element.

3.1 Validation

Documents can be validated (conforms to a DTD) by selecting "a/idate from the Tools menu, or clicking the Validate
button on the toolbar. The current XML document contents are checked against the constraints specified in the asso-
ciated DTD, to ensure that the document format and content conforms to the DTD specifications.

If XML Pro encounters an error during the process, an error message is generated, similar to this:

Invalid element 'PARTNUM' in content of weight. Expected [PCDATA]

The message indicates the error encountered, and XML Pro highlights the item that generated the error in the docu-
ment tree view. The validation process stops when an error is generated, so you should correct the error. Once is has
been corrected, try validating the document again, and repeat this process until validation is successful with no error
messages displayed.

3.1.1 DTD Errors

XML Pro recognizes two types of DTD errors:

1. A missing DTD. If XML Pro cannot find the associated DTD, an error is generated, and the
XML file will not load.

2. DTD syntax errors. If XML Pro is unable to correctly parse the associated DTD due to an error
in the DTD file, an error message is generated, similar to the one below:

Error opening document: Expected DOCTYPE instead of Entity At Line 2

The error message will indicate what the error is (if possible), and give a line number, so the DTD can be corrected.
3.1.2 Handling Invalid Documents

XML Pro will open documents which have an associated DTD, but which are invalid. XML Pro will not open an
XML document that is not well-formed. When opening a document that is invalid, XML Pro generates an error
message indicating the problem. The problem should be corrected, and the document successfully validated before

editing the document within XML Pro.
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NOTE: Well-formed means that all tags (elements) in the document match, all attribute values match and all entities
for the element are declared.

XML Pro allows invalid documents to be saved, but first prompts you to make sure you are aware the document has
not been validated.

L1 Associate DTD |
~DTD Settings

Name  |CATALOG
SYSTEM [catalon.dtd
PUBLIC |

Browsze |

ok | R emowve I Cancel

Figure 3-1. Associate DT'D dialog box

3.2 Naming the DTD

The Name field in the Associate D'T'D dialog is not user-definable. In accordance with the XML 1.0 Specification, the
"name" of the associated DTD actually corresponds to the DOCTYPE (the document type declaration) in the tag
which specifies the DTD association in the XML file. This DOCTYPE must match the name of the root element in
your document, so this will be determined automatically.

3.3 The DTD Location
DTD location is specified in the Sysen text field. This is to correspond with the convention for specifying the location
of DTD's within the XML document itself. The location can be:

1. A file name. The DTD and XMIL. document must occupy the same directory.

2. A file URL. You must use the "file:/" desctiptot, and provide the full path to the location of the
DTD.

3. A WWW URL. For example, "http:/ /www.myserver.com/mydtd.dtd."
3.3.1 The Public String

The Public field corresponds to the value of the Pubii attribute in the DOCTYPE element that defines the DTD
associated with the document.

3.4 Removing an Association
To remove a DTD association, open the Assocate DT'D dialog and click the Rezzove button.

NOTE: Any changes made to the DTD Association will not take effect until the document is saved and reloaded.
16



3.5 PCDATA

XML Pro supports viewing PCDATA items as icons in the tree view, letting you see the overall document structure
more easily. XML Pro lets you add and/or delete PCDATA.

3.5.1 Adding PCDATA

PCDATA can be added to a document by right clicking on the insertion point, and selecting .Add PCDATA from the
Pop-up Menu.

3.5.2 Removing PCDATA

There are two ways to remove PCDATA:

1. Right click on the PCDATA you wish to remove, and select Delete.

2. Select the PCDATA you wish to remove, and select Delete Element from the Tools menu. Once
PCDATA is removed and the document is saved, the deleted PCDATA is no longer available.

3.5.3 Editing PCDATA

To edit PCDATA, click on it. This loads the content into the Text Editing pane of the editor, where you can type addi-
tional text, or cut, copy and paste text and information into the PCDATA.

3.6 CDATA

CDATA can be any kind of character data, other than elements, entities or attributes. CDATA is represented in the
document tree with the CDATA icon and label, and the contents of the CDATA element are not shown in the tree.
Once a CDATA item has been added to the tree, the contents can be edited in the Text Editing pane of the main win-
dow. XML Pro lets you add and/or delete CDATA.

3.6.1 Adding CDATA
CDATA can be added by right clicking on the insertion point, and selecting .Add CDATA from the Pop-up Menu.
3.6.2 Deleting CDATA

There are two ways to delete CDATA:

1. Right click on the CDATA you wish to delete, and select Defete.
2. Select the CDATA you wish to delete, and select Delte Element from the Tools menu.

Once CDATA is removed and the document is saved, the deleted CDATA is no longer available.

3.7 Comments

XML Pro also supports XML comments. XML comments are represented in the document tree with the Comment
Icon and Label. A comment's contents can be edited in the main window Text Editing pane.
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3.7.1 Adding Comments

Comments can be added to a document by clicking the right mouse button on the insertion point, and then selecting
Add Comment trom the Pop-up Menu.

3.7.2 Removing Comments

There are two ways to remove a Comment:

* Right click on the Comment you wish to remove, and select Defeze. This removes the Comment

from the document.

or

* Select the Comment you wish to remove, and select Delkete Element from the Tools menu. This

deletes the Comment from the document.

Like CDATA and PCDATA, once a Comment is removed and the document saved, it no longer is available.
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